LibUHD & GNU Radio version mismatches

I ran into a ver mismatch with @EttusResearch UHD libraries. For Ubuntu 22.04, they moved to ver 4.3. @gnuradio has gnuradio_uhd built against libuhd ver 4.1 in their repo though. The solution was to downgrade libuhd and force libuhd to be 4.1:

sudo apt install libuhd-dev=4.1.0.5-3

Leave a Reply

Your email address will not be published. Required fields are marked *